Jump to content
Sign in to follow this  
C4C2

Affiliate Search - How on earth is this supposed to work?

Recommended Posts

C4C2    10
C4C2

I am toying with the idea of giving you guys a bit of support by making use of the affiliate search feather that you have provided.

 

In order to understand how it works I went about setting up a basic example on my website where there is a page that contains all of the provided code.

 

So, it seems great, i navigate to the webpage on my website and am greeted with the search feature... I enter a random term like 'tennis' and that is where things go pear shaped...

 

I get redirected to : http://www.bidorbuy.co.za/jsp/affiliate/affiliateSearchPreview.jsp that is a blank page, exactly the same as on my website but on yours... As in no search results relating to tennis... I have to put 'tennis' again and click on search to get any results.

 

I understand that yes, my user id has been passed as a token so you have effectively tracked that the search and the current user session came from came from me but i mean from the users point of view... Why on earth would they want to fill out the same thing twice?

 

I have no idea how it is supposed to work but if this is what you guys had intended... I mean really I hope that you are not hoping for very much... There is no advice at all that i have found on how to customize this feature or any information relating to show to make use of it at all and its quite frustrating.

 

Is it supposed to work like this? Because i was expecting something more like google's search feature which makes alot more sense and if this is the way it should work then really it just seems as if it would too futile to make an effort over.

 

The example that you provide with the code works awesome... But mine does not work like that so i have either done something wrong (which would be hard) or your example is misleading. Either way i feel a bit let down!

 

Can you even direct it to something like href="http://www.bidorbuy.co.za/jsp/system/Referral.jsp?ID=user_details&search=tennis_racket"? It doesn't look like it...

Edited by C4C2

Share this post


Link to post
Share on other sites
MacMuffin    0
MacMuffin

Hi there - we messed this one up. The Affiliate Search widget was broken and searches did not return any results. It was fixed just now and in order to get it working on your end, you will need to regenerate the widget-code and deploy it on your website.

 

If you still struggle, please post your website URL here and we will have a look.

Share this post


Link to post
Share on other sites
Just Beachin    10
Just Beachin

Huh?????

Share this post


Link to post
Share on other sites
C4C2    10
C4C2

Hey!

 

Well, it appears to be work in progress i guess.

 

I have tried it out again but its roughly the same situation.

 

On my page i put in "tennis". Upon searching i get sent through to your page. Now the difference is that there is writing in the input. It contains the string "titledesc". There are still no results, its just the string in the input on your page that never used to be there and now is.

 

Now we both know that "titledesc" is not "tennis"...

 

In any case, this is what i would expect :

 

The user enters "tennis", clicks search and then is redirected to your page. Your page is populated with results relating to "tennis". Am i far off here or is this what you were intending to achieve because if so it is not working.

 

Your input has been appreciated and i will be waiting for your next reply, thanks!

Edited by C4C2

Share this post


Link to post
Share on other sites
C4C2    10
C4C2
Huh?????

 

At least someone understands me :)

Share this post


Link to post
Share on other sites
MacMuffin    0
MacMuffin

Please post a link to your website...

Share this post


Link to post
Share on other sites
MacMuffin    0
MacMuffin

 

Hi there - it looks like this page is gone now - I get a 410 error when accessing the URL. The widget should work, provided that you re-generated the widget code after our fix. When I looked at it on Saturday it did not look like you did that.

 

Please regenerate the widget code and let me know the outcome....

Share this post


Link to post
Share on other sites
C4C2    10
C4C2
Hi there - it looks like this page is gone now - I get a 410 error when accessing the URL. The widget should work, provided that you re-generated the widget code after our fix. When I looked at it on Saturday it did not look like you did that.

 

Please regenerate the widget code and let me know the outcome....

 

 

Hi there,

 

The link does work, if there was an error it must have been a temporary technical issue.

 

I did regenerate the ad code and as stated there is a change between the new code and the previous release. However, it still does not work, in my opinion. Please try the link again and input any search term, you will see that it really just does not work as it should.

 

Thanks!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×