Jump to content
Sign in to follow this  
Angolo Antico

anyone else with parcels going missing in Witpos Hub ?

Recommended Posts

Little Miss Muffet

I have been trying for 2 weeks to get an answer from Witpos about a parcel that has been stuck there since 6th October.I have been shoved from pillar to post. From Florence to Mildred to Ansie then to Julie.

Apparently this parcel was sent for investigation because it was damaged.More likely"Contents stolen" rather than "Damaged"

Well did I use the Kings language this morning ."No one has the right to open a parcel addressed to me. What sort of "Kings" country do we live in?" :smile: Makes me sick.

Julie tells me they are waiting for an answer from Mr P--Do not know how the name is spelt. I told her that she will not wait for an answer but go to Mr. P and get an answer.

Hubby shouts from the room "Don't mess with Quiny"

Edited by geewhizz

Share this post


Link to post
Share on other sites
alloway65

I had a package missing for about two weeks, spoke to my postmaster the other day she eventually traced it to Houghton, instead of Honeydew, it arrived at my PO this afternoon. The package contained a few Mandela items....maybe the PO was going to have them signed by the great man but they did not realize he is very, very ill.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...