Jump to content
Sign in to follow this  
voldermort

Problems With BoB??

Recommended Posts

Guest MacMuffin

I was indeed under the pillows last night and missed out what might have happened. I had a look at our performance stats and we have not recorded any unusual behavior over the last week or during the timeframe mentioned last night. Our response time did increase from 300ms to 400ms after 11pm last night and our severs reported pages served between 500ms-3seconds - all quite normal traffic behavior.

 

We do have alerting in place if requests take long (i.e. above 30 seconds) or we experience a slowdown on our database, but none of those thresholds had been met.

 

Not sure if this is related to ISP issues on your side as we typically get notifications from Internet Solutions if they experience connectivity issues which could affect your experience.

 

Can you guys confirm if you only had slow responses from bidorbuy.co.za or if other sites showed the same behaviour. If you could share your ISP and what method of connectivity you use that would be helpful. Also in future, it would help if you go to speedtest.net and do a speedtest to rule out any ISP issues on your side.

Share this post


Link to post
Share on other sites
JPBon

Hi Mac I tested a few sites last night and the only one I had problems in opening pages with was BOB...both the site and the forum. It would just hang. I also struggled to get on completely for a few minutes. I would say it lasted about an hour or so then went back to normal.

Share this post


Link to post
Share on other sites
ATA STAMP CENTRE

HI MAC

Definitely was only bob site-for a few hours it was very slow to refresh and open pages and the forum-this was on my adsl with mweb as service provider,I then switched to my mtn fastlink wireless modem and while it was better it was still very slow on the bob site.Could not be traffic related as there could not have been that much activity last night.Suddenly came right after about two hours at around 9 45 pm last night and was then back to normal on both my internet facilities.

neil

Share this post


Link to post
Share on other sites
voldermort

I first noticed it just before 8pm while doing some relisting.......as said if I clicked to view any of my items it would show up as 2 page views instead of just one extra as it should do (incidentally it is still doing this on some of my open items) at the same time it became painfully slow to refresh any BoB pages including the forum, and it was only BoB as I was also googling at the same time and other sites were working fine.

When I checked at about 11pm it was sorted out.

Not sure if this is what you are asking for but I'm with Telkom/ADSL.

Share this post


Link to post
Share on other sites
Cali Craft and Gems

Re the "double page view" when you check the new listing has been happening since the weekend. I didn't mention it before as it was not that important - just irritating!

 

Re the slow site last night - only the BoB pages. I've got the uncapped Mweb ADSL setup and at one stage I actually left the office and returned a while later as it was simply too frustrating! By example, I was trying to edit a listing and it took several minutes just to open the "other" standard info excluding the thumbnail image and the main listing section (only showed one line of HTML code). It eventually came right after a while thus me working until after 1am again just to try and catch up.

Share this post


Link to post
Share on other sites
Guest MacMuffin

We received not much feedback from Internet Solutions, but they did mention that they experienced international capacity issues yesterday. This is however unrelated and should not affect our customer experience/responsiveness as all of you access BoB from SA. Still waiting for some answers, as nothing was done on our part to cause (or fix) the slow responses last night - which indicates to me that it is an ISP issue.

 

Regarding the "double page view": The page-view counter increases as soon as a user accesses the page (even if you as the seller open the item multiple times the counter increases). I have tested the behaviour in production and a single request results in a single increase of the counter. With regards to the "mysterious" increase of pageviews there are a number of explanations for this:

  • If you have any browser extensions (such as Google Toolbar, Alexa) installed, those will submit anonymous tracking information to Google/Alexa/Yahoo/Bing which in turn will crawl the page and result in an additional hit.
  • Any other application local to your PC (such as Antivirus or security software) might pre-scan the page or a proxy/caching server at your ISP might access the same page.
  • We have added extra meta-information to all our items (called hproduct microformat) which allows search engines, Facebook and other crawlers to better identify products and display them in searches, which has resulted that our crawl rate has increased and search engines will re-crawl items and items in the "What's New"-page resulting in extra count.
  • You might have noticed the Facebook "Like" buttons on the item pages. As soon as any user "Likes" your item, Facebook will come and visit to retrieve extra product information to display on the user's wall.

 

If in future you do experience any slowdowns on our site, please do the following so that we can provide Internet Solutions with more detail to narrow the problem down:

- Time/duration of incident

- Speedtest result via speedtest.net (pick Johannesburg as a monitoring point and then also pick London)

- Which local sites did you visit which did not show the slow response?

- Did you experience slowdowns on other local/international sites or just bob?

- For the technically inclined a ping bidorbuy.co.za and a traceroute bidorbuy.co.za would be of tremendous value

Share this post


Link to post
Share on other sites
voldermort

I'm not sure I understand exactly what you are saying re: the double page views however................I have only noticed this happening since Sunday, I have not changed/updated/upgraded any PC security etc, it is not happening only on my new listings but on any random items eg: http://www.bidorbuy.co.za/jsp/item/Item.jsp?Trade_TradeId=30916071

 

http://www.bidorbuy.co.za/jsp/item/Item.jsp?Trade_TradeId=30916071

 

lets try this one

 

http://www.bidorbuy.co.za/jsp/item/Item.jsp?Trade_TradeId=30756823

 

& this particular one is giving me a triple page view

 

http://www.bidorbuy.co.za/jsp/item/Item.jsp?Trade_TradeId=30690512

 

 

that is not a new item yet is just one of many that keeps giving me a double page view, if this is due to a FaceBook like button, then somebody is liking a hell of a lot of my items.

Im sure this must be affecting many other users as well.

Edited by voldermort
tring to get an item that does not show error message

Share this post


Link to post
Share on other sites
voldermort

Any idea why the above item is giving me an error message????

Share this post


Link to post
Share on other sites
qball

The link contains the following on the end of it - ............that. If you remove this it does display.

Share this post


Link to post
Share on other sites
voldermort
The link contains the following on the end of it - ............that. If you remove this it does display.

 

I did and it does, thanks :blush:

Share this post


Link to post
Share on other sites
qball

Not too sure why that was on the end of the URL link? :wondering:

Share this post


Link to post
Share on other sites
voldermort

Lets just say a gremlin on BoB forgot to go onto a new line after copying in the item and just blissfully carried on typing "that is not blah blah blah" on the same line :oops:

Share this post


Link to post
Share on other sites
qball

Understood... :grin:

Share this post


Link to post
Share on other sites
lilythepink

I haven't changed any of the settings on my computer either - yet whilst I was working on my Seller and Buyer pages on BoB a few minutes ago, I kept finding my cursor moving around the page and the entire feel of my mouse was "heavy". It's not happening on the forum or any of my other computer programs. (Sorry, I don't know the computer 'wordology' for what is happening but hope you understand what I'm saying!) :wondering:

Share this post


Link to post
Share on other sites
Guest MacMuffin
I'm not sure I understand exactly what you are saying re: the double page views however................I have only noticed this happening since Sunday, I have not changed/updated/upgraded any PC security etc, it is not happening only on my new listings but on any random items eg: http://www.bidorbuy.co.za/jsp/item/Item.jsp?Trade_TradeId=30916071

 

Horror Fiction - Dean Koontz-Brother Odd was listed for R70.00 on 11 Jan at 18:01 by voldermort in Cape Town (ID:30916071)

 

lets try this one

 

Historical Fiction - Dark Fire By C.J.Sansom was listed for R50.00 on 11 Jan at 18:01 by voldermort in Cape Town (ID:30756823)

 

& this particular one is giving me a triple page view

 

First Day Covers & Sheets - Orange River Colony-Brief Kaart Duplicate Unused was listed for R225.00 on 11 Jan at 19:01 by voldermort in Cape Town (ID:30690512)

 

 

that is not a new item yet is just one of many that keeps giving me a double page view, if this is due to a FaceBook like button, then somebody is liking a hell of a lot of my items.

Im sure this must be affecting many other users as well.

 

I have not been able to reproduce the multi-page view count. Looking at our server logs, requests to those item pages have been made from various IP addresses. The item "30690512" had 7 pageviews when I looked it yesterday. My testing and a number of other users (I assume guys reading this post) have also clicked the item and from the server-logs I can account for the currently 12 pageviews (i.e. the extra 5 clicks since yesterday).

Share this post


Link to post
Share on other sites
JPBon

MacMuffles I dont think voldermort is talking about the page view counts, but that she sees the page split and doubled when she views her items.

 

I was also getting some weird views of my aucton pages, with lots of things distorted.

Share this post


Link to post
Share on other sites
Guest MacMuffin
MacMuffles I dont think voldermort is talking about the page view counts, but that she sees the page split and doubled when she views her items.

 

I was also getting some weird views of my aucton pages, with lots of things distorted.

 

Sorry - I thought "doubled pageviews" was a problem with the actual view count. If your pages are distorted and it is consistent across bidorbuy.co.za, then I suggest you force a page-refresh (CTRL+F5) or delete your browser's cache. We did have a release last week Thursday which added some new UI elements - those changes typically don't impact end users. We do find that some ISPs and companies have aggressive caching policies where they ignore websites caching rules and continue serving old stylesheets and images. A forced page-refresh will resolve those issues.

Share this post


Link to post
Share on other sites
Digitrade

This is starting top get irritating! Some pages takes forever to open. I waited so long for a page to open, that I actually had time to write down the URL that shows at the bottom of the screen while you download. It was:

 

Waiting for http://www.facebook.com/plugins/like.php?href=http%3A%2Fwww.bidorbuy.co.za.

 

I hope that this will give you guys a starting point, because downloads are very slow on Bidorbuy!

Share this post


Link to post
Share on other sites
Guest MacMuffin
This is starting top get irritating! Some pages takes forever to open. I waited so long for a page to open, that I actually had time to write down the URL that shows at the bottom of the screen while you download. It was:

 

Waiting for http://www.facebook.com/plugins/like.php?href=http%3A%2Fwww.bidorbuy.co.za.

 

I hope that this will give you guys a starting point, because downloads are very slow on Bidorbuy!

 

What browser/OS are you running and what is your internet connectivity? The Facebook-like button runs in a separate IFRAME which loads in a deferred fashion to the rest of the page. The user experience should be that the whole item page will load and with some small delay (100-500ms) the Facebook button will render.

 

Can you please also do me a favor and issue the following commands from a command line and post the results:

ping www.bidorbuy.co.za

tracert www.bidorbuy.co.za

 

Lastly does the slowness apply to all item pages or just a select few? Lately some sellers have decided to embed large MP3s and other bells & whistles on their pages which does give a very bad user experience. If you have some item-ids where this is reproducible, please post them as well.

Share this post


Link to post
Share on other sites
Digitrade

I use IE8 with XP Pro, Telkomadsl 384 with @lantic as ISP.

The slowness is random. You might try to open a page, and it takes forever.

The very next time I try to open that same page, it will open without hassles, but then the "facebook" part in the URL is gone, and it downloads "images" next.

The pages that I accessed had no MP3's or any funny stuff.

Share this post


Link to post
Share on other sites
Guest MacMuffin
I use IE8 with XP Pro, Telkomadsl 384 with @lantic as ISP.

The slowness is random. You might try to open a page, and it takes forever.

The very next time I try to open that same page, it will open without hassles, but then the "facebook" part in the URL is gone, and it downloads "images" next.

The pages that I accessed had no MP3's or any funny stuff.

 

Thanks. If you could run the above "tracert" command and then also do a speedtest via Speedtest.net - The Global Broadband Speed Test and post the resulting link that would help (especially during the time of a slowdown). It would also help to get the URL of the page you are requesting so that we can have a look at the request on our servers.

 

Performance of individual item pages is however affected how sellers host their images (some use their own hosting, the majority uses BoB and others use image services such as Flickr/Amazon/Picasa).

 

I have simulated a test on a 384KB line for the following item: Soccer - Andres Iniesta signed WC 2010 Photo *** RARE RARE *** COA Incld for sale in Johannesburg (ID:31364020)

 

The above is a typical item page which I picked randomly from the homepage and if a first time user visits the item page he/she will have to download 540KB (the majority of data will be cached in the browser and will never be downloaded again), but if you look at the test-results you will notice the blue-graphs which are the users images which are hosted in Europe and take between 4-9 seconds each to download.

 

One would also think that accessing that sellers page again would be quicker (which it is, as all bidorbuy resources are cached and the page displays in 3,4 seconds), a look at the results show that the sellers hosting provider has a misconfigured server which forces the re-check of all those images again.

 

If you notice bidorbuy pages (such as category listings) to be slow, than it is very likely an ISP issue or possibly a slowdown on our end, but even at our busiest times (Wednesday / Friday before auction close) we have ample capacity that the user experience is not affected.

 

If you do notice slow responses on item pages, it is very likely that the seller has inserted images which are hosted on a slow server or are not even hosted locally and suffer then from huge download times. Unfortunately it is impossible for us to look at trades individually, but occasionally we do inform sellers of listing problems.

Share this post


Link to post
Share on other sites
Vinyl Lady Decals
I use IE8 with XP Pro, Telkomadsl 384 with @lantic as ISP.

The slowness is random. You might try to open a page, and it takes forever.

The very next time I try to open that same page, it will open without hassles, but then the "facebook" part in the URL is gone, and it downloads "images" next.

The pages that I accessed had no MP3's or any funny stuff.

 

Hi Digitrade

 

Your probem could be with @tlantic.

My mom has this ISP and her internet is incredibly slow, she's in the process of changing to another ISP at the moment.

Share this post


Link to post
Share on other sites
Digitrade

Hi Digitrade

 

Your probem could be with @tlantic.

My mom has this ISP and her internet is incredibly slow, she's in the process of changing to another ISP at the moment.

 

Tananka,

They have different packages. I am on a 4Gb Gold, which has a much quicker connectivity than Bronze for example. I am very happy with them.

I do not have problems with any download or upload speed. It seems to be better now. This only happened on the BoB pages, and nowhere else.

It seems that this Facebook plug-in thingy had something to do with it.

Share this post


Link to post
Share on other sites
lilythepink

Thank you to whoever caught the gremlin that was slowing down our BoB pages! I've had a carefree day today!

Share this post


Link to post
Share on other sites
Guest MacMuffin

I don't think the Facebook Likes have anything to do with the speed. We did quite comprehensive testing we introducing this feature to ensure that pagespeed is not negatively affected. With our implementation, the Facebook Like actually goes of async and does not slow down anything. We do hope that buyers will make use of this and promote your items on their walls to give more exposure.

 

I did get some more feedback from Internet Solutions where they acknowledged that their have been some backhaul issues in their retail segments which could have adversely affected ADSL users connecting into their backbone. I know that Afrihost users have been affected (not sure if Atlantic uses IS or someone else). We also experienced office ADSL issues through MWEB and I picked up similar sentiments from other MWEB users.

 

None of those backhaul issues are however affecting our hosting environment and we unfortunately have not caught that gremlin ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...